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1- Abrir Huygens Professional                  o Huygens Essential                

2- Abrir la imagen a analizar (File → Open)

3- La deconvolución de la imagen es opcional pero ayuda a definir las estructuras, elimina 
fondo y corrige aberraciones esféricas.

3- Abrir el analizador (Analysis → Object Analyzer Advanced)

4- Un buen análisis requiere una buena segmentación de la imagen (separar los voxels de 
interés del background como objetos independientes).

5- Excluiremos objetos demasiado pequeños mediante garbage (objetos inferiores a un 
determinado número de voxels serán eliminados de la imagen).

6- La visualización 3D será Iso-Surface (imagen con efecto “plastificado”).

7- Realizaremos el análisis 3D de interés. Sólo se podrá analizar la relación entre canales de 2 
en 2.

Pasos generales 
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Threshold: valor de intensidad a partir del cual el voxel será tenido en cuenta en el análisis. 
Los voxel adyacentes se agrupan formando los distintos objetos.  

Watershed: separa objetos cercanos buscando valores locales mínimos.
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Seed: threshold secundario que permite seleccionar los objetos más intensos dentro de un 
determinado threshold.  Permite seleccionar objetos más grandes.

1 objeto pequeño 1 objeto mediano
1 objeto grande

1 objeto mediano
1 objeto grande

Garbage: elimina objetos con menor número de voxel que el indicado. Útil para limpiar la 
imagen y deshacernos de objetos minúsculos que realmente son fondo.

Segmentación
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Se pueden definir 2 canales 
para segmentar y analizar: 

Primary (P) y Secondary (S)

Elegir el canal:
Chan 0 = primer canal
Chan 1 = segundo canal…

Define el rango de color 
de los diferentes 

objetos. Juntando las 
flechas todos serán del 

mismo color

P y S se visualizan como “Iso Surfaces”(efecto plastificado);
MIP como Maximum Intensity Projection (puedes aumentar la
calidad del MIP en Options > High quality MIP).

Se puede definir 1 canal 
como MIP. Útil para tener 

una referencia visual de los 
datos sin segmentar y para 

hacer una ROI

Visualización alternativa 
del threshold y el seed. 

Permite modificar el 
Garbage y usar Watershed

Seed

Threshold

Segmentación
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Una vez definida la segmentación, se puede guardar

y volver a cargar

Execute history será útil después, cuando ya 
hayamos hecho algún análisis o alguna 
modificación de la imagen, si queremos 
reproducirlo de nuevo (como un macro). 

Segmentación
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Analiza el objeto que se seleccione.

Selecciona los objetos que se encuentran dentro de ese área.

Elimina el objeto que se seleccione.

Define como “Ancla” (objeto de referencia) el objeto que se seleccione. El segundo clic elimina la definición.

Permite rotar la imagen en 3D manipulándola con el ratón. También se puede hacer con Tilt y Twist.

Permite mover la imagen en 2D.

Permite mover la imagen en 2D pero también mueve el mural de fondo.

Mueve la ROI (tiene que haber sido definida previamente).

Para crear una ROI dibuja un área 2D con         y selecciona el icono “añadir selección a la ROI”         . La 
selección de voxel será entonces proyectada en 3D, perpendicular a la pantalla, para convertirla en un 
volumen. Para explorar otras opciones de crear ROIs ir a la diapo “Regiones de interés”.

Borra la ROI.

Mantiene los objetos que se encuentran dentro de la ROI, elimina los demás.

Define como Ancla los objetos que se encuentran dentro de la ROI.

Elimina los voxel de la imagen que se encuentran fuera de la ROI.

Elimina los voxel de la ROI que están fuera del área seleccionada. La selección se hace teniendo activo        . 

Elimina los voxel de la ROI que están dentro del área seleccionada. La selección se teniendo activo         .

Añade más voxel a la ROI. La selección se hace teniendo activo        . 

Interacción con los objetos 
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Mantiene los objetos que se encuentran dentro del área seleccionada, elimina el resto

Elimina los objetos que se encuentran dentro del área seleccionada

Define como Ancla los objetos que se encuentran dentro del área seleccionada

Elimina los objetos Ancla

Elimina la definición del objeto como Ancla volviendo ser un objeto normal

Mantiene los Anclas, elimina los demás objetos de ese canal

Carga la imagen original, mantiene la segmentación definida. Por ejemplo, hemos borrado un objeto por error.

Deshace la última acción.

P: analiza o aplica una acción sólo en el canal P actual.

S: analiza o aplica una acción sólo en el canal S actual.

PS: analiza o aplica una acción en los canales P y S actuales.

All: analiza los canales P y S actuales, pero aplica una acción a todos los canales (aunque no estén en uso en ese 

momento), por ejemplo eliminar voxel.

Sobrescribe la imagen considerada como original.

Interacción con los objetos 
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Revisar Options → Relaxed selection. Si está activo, todos los objetos que estén tocando el límite 
de la selección también serán tenidos en cuenta. Si no está activo, serán descartados.

Con Relaxed selection activo Con Relaxed selection NO activo

ROI

Objects
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Mide todos los 
objetos

Mide sólo el 
objeto que 
selecciones

Elige el tipo de análisis que quieres 
realizar (ver siguiente diapo)

Análisis

> 

Object Segmentation 

Scnd. 

Tr¡ans~reney 0 .60 

1 
Brightness 0.80 

1 
o o 

Chan O 
Applyto: 

ROl preferences 

Tnnspare1 

Bri;ht:rw s s -

D Render mode 

Twist 0.0 1 1. 1 
o (eh O): 462 obj. - 1 (eh 1 ): 36 obJ. No anchor objeds seleded 
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Distance to reference 
objects: distancia a un 
objeto de referencia (ancla).

Small particles geometry:
geometría de los objetos 
(tamaño, dimensiones, 
esfericidad…).

Correlation inside 
channels: busca el objeto 
más cercano del mismo 
canal y calcula la distancia.

Correlation between 
channels: busca el objeto 
más cercano del otro canal 
y calcula la distancia.

Colocalization 
(intersection): 
colocalización en volumen e 
intensidad entre dos 
canales.

Location inside a flat 
nucleous: posición del 
objeto respecto a una ROI 
plana.

Location inside a round 
nucleous: posición del 
objeto respecto a una ROI.

Intensity in the other 
channel: intensidad de un 
objeto en el otro canal.

Análisis
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Tipos de 
análisis

Al seleccionar un análisis nos da su 
descripción

Al seleccionar un parámetro nos da su descripción, así como la 
nomenclatura que llevará en la tabla de resultados

En Options → Configure reported parameters se pueden añadir más parámetros al análisis.

Eliges dónde quieres que se visualicen los datos, 
si sólo en la tabla o también en la imagen

Análisis
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Una vez que hagamos clic en el botón          saldrá la tabla de resultados. 

Canal

P = 0
S = 1
En caso de seleccionar dos objetos que estén en el mismo punto de mira, pero no están colocalizando, se les asigna una 
letra F (front = delante) o una B (back = detrás) para saber su posición relativa.

Valores del análisis

Nº del 
objeto

Borra los datos 
de la tabla

Exporta los resultados 
(txt, csv o Matlab)*

Clic derecho en cualquiera de las filas o 
columnas y saldrá un desplegable con 
diferentes opciones para aplicar a los 
datos:

*Ojo!! Al exportar los datos la forma más 
segura es csv!! 
Comprobar que los valores son los mismos. 
Por ejemplo, 497.54 lo exporta en csv como 
4.975400E+02 pero si lo exportamos como 
txt y lo abrimos posteriormente en Excel 
aparece como 4.98E+08

Análisis. Resultados
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Selecciona el parámetro en el que aplicar el filtro

Descarta los objetos…

Si auto clean está activo la tabla se quedará vacía al filtrarla y 
tendremos que volver a hacer clic en el botón de analizar!!

Si queremos volver a ver la imagen sin filtrar podemos volver a los datos originales         . 
También en History → Reload original data

Valor fijo o en comparación con otro parámetro

Podemos filtrar los resultados       . Elegir a quién aplicarlo:

Al aplicar el filtro los objetos 
descartados se borran tanto de la 

tabla como de la imagen

Análisis. Filtrar resultados
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En el Object Analyzer hacer una ROI no quiere decir que sean sólo esos objetos los que se van a analizar 
(como puede ocurrir con otros programas como el ImageJ). Aquí las ROIs se usan para:

Regiones de interés (ROI)

 Descartar objetos enteros

 Eliminar datos de la imagen 
(aunque formen parte de un 
objeto)

 Seleccionar objetos como 
anclas 

 Referencia en la localización de 
objetos
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Las ROIs se pueden definir de diferentes formas:

 Mediante una selección:        →       

 Con anclas ya definidas: 

ROI → Set → Enclose anchors in a box (ROI en forma de caja, con las dimensiones del ancla).
ROI → Set → Make coincide to anchors (ROI con la forma del ancla, excluidos huecos internos).
ROI → Set → Envelop anchors (ROI con la forma de la superficie del ancla, incluyendo huecos).

 Con todos los objetos:

ROI → Set → Make coincide to objects

 Usando la colocalización entre objetos:

ROI → Set → Make coincide to intersection (ROI con los voxel que colocalizan entre los 
objetos).

 Con MIP

ROI → Set → Set using MIP threshold
ROI → Modify → Fill inner cavities (si se quieren rellenar los huecos internos)
ROI → Modify → Fill inner and cutoff cavities (si se quieren rellenar huecos internos y externos 
para que la periferia de la ROI sea plana).

ROI
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Una vez definida, se puede:

Guardar: ROI → Storage → Save current ROI to file. 

Volver a cargar: ROI → Storage → Load ROI from file. 

Hacer operaciones con la ROI que está definida en ese momento:

Sumarla: ROI → Storage → Add ROI from file. 

Restarla: ROI → Storage → Subtract ROI from file. 

Calcular la intersección: ROI → Storage → Intersect with ROI from file. 

Una vez aplicado algún procesamiento, por ejemplo , es útil sobreescribir la imagen de referencia         
si queremos seguir trabajando con ella. De esta forma podemos probar distintos análisis y volver a este
punto en cualquier momento.

ROI
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Si hemos hecho una ROI, su análisis aparecerá al final de la tabla: ROI_P y ROI_S.  
Ojo!! Si la hemos hecho mediante una selección con         el análisis es de todo su volumen (no de los 
objetos incluidos en ella). 

ROI

Para analizar únicamente los objetos que 
contiene la ROI habría que eliminar el resto de 
objetos        .

ROI_P y ROI_S sólo se van reflejar un tamaño de 
interés si la ROI es definida con anclas, objetos, 
colocalización entre objetos...

ROI
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Podemos guardarla en File → Save Scene
En Options podremos elegir varias 
características relativas al aspecto 
de la imagen:

Bounding 
box

ID label

Logo
Scale bar

Reference 
cube

Screen 
tooltips

*Tamaño de la imagen: Canvas va 
ajustando el tamaño automáticamente.

**Transparencia:

*

**

Simple Normal Deep

Visualización de la imagen
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Length (L): eje 
más largo

Width axial (WiAx): lado más largo 
perpendicular a L en el eje axial.

Width lateral (WiLatC): lado más largo 
perpendicular a L en el eje lateral.

La toma de imagen produce una “elongación falsa” de los objetos debida a la aberración 
esférica, incluso en imágenes deconvolucionadas. Usando los valores Lenght , WiAx y 
WiLatC estaremos minimizando esa sobre-estimación de las dimensiones de los objetos 
(en Options → Configure reported parameters podemos configurar la lista de parámetros 
si queremos obtener también los “no corregidos”).

Lo mismo ocurre en el cálculo de la esfericidad. Si usamos el cálculo AxSph, en vez de 
AxSphPB, estaremos minimizando la aberración esférica.

https://svi.nl/ObjectAnalyzerGeometry

Geometría en Object Analyzer
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History = macro

Una vez definida la segmentación y el análisis, se 
puede guardar

y volver a cargar

Reproduce todas las acciones realizadas (como si 
fuera un macro). 

No se puede modificar 
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Ejemplos
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Distancia a objetos de referencia

1- Define el Ancla que actuará como objeto de referencia

2- Elige el tipo de análisis:

3- Analiza

Distance to reference 
objects: distancia a un 
objeto de referencia (ancla).

Distancia entre 
los centros de 

masas (CM)

Distancia del 
CM del objeto a 
la superficie del 

objeto de 
referencia
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Location inside a flat 
nucleous: posición del 
objeto respecto a una ROI 
plana.

Location inside a round 
nucleous: posición del 
objeto respecto a una ROI.

Localización dentro del núcleo

1- Define la ROI que actuará como núcleo (ver diapositivas de definición de ROIs).

2- Elige el tipo de análisis:

3- Analiza

NÚCLEO PLANO NÚCLEO 3D

Calcula la distancia entre el centro 
de masas del objeto y la ROI. 

Calcula la distancia más corta a la 
superficie de la ROI en el eje XY.

Calcula la distancia entre el centro 
de masas del objeto y la ROI. 

Calcula la distancia más corta a la 
superficie de la ROI en cualquier 
dirección.
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https://svi.nl/HomePage

Si os registráis en la página de Huygens tendréis mucho contenido didáctico 
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